Jump to content





Baumrb

LED headlights

Recommended Posts

no problem with mine......i did notice after installing my led bulbs in the fog lights that when i turn on my headlights my fog lights come on automatically without having to use the headlight button, never noticed that happening before i installed the led bulbs. any others notice this. its fine with me but was wondering if any one else notice it as well....

Share this post


Link to post
Share on other sites
On 10/24/2018 at 11:22 AM, Ghost said:

I tried LED in low beams a couple years ago and they made my radio reception kind of fuzzy everytime headlights were on - anyone else notice this problem or is it just the brand I bought?

 

Cheap LEDs will do that. 

Share this post


Link to post
Share on other sites

HI, late post to the LED question.  Was there a consensus of a drop in LED high or low unit?  One post explained it was the worst thing to do and others mentioned modifying the plugs with resistors, etc.  I have a 2015 DJ SXT and would like to convert over to the LEDs for a nice brighter white light.

Share this post


Link to post
Share on other sites
7 hours ago, martyman.geo said:

HI, late post to the LED question.  Was there a consensus of a drop in LED high or low unit?  One post explained it was the worst thing to do and others mentioned modifying the plugs with resistors, etc.  I have a 2015 DJ SXT and would like to convert over to the LEDs for a nice brighter white light.

I have not put mine in yet, they will be in this weekend, but I have done countless led/hid installs. Always get a canbus for your led just to be safe, better to have it and not need it, then to need it and not have it. Just get the right size, and when you put the led bulb in, make sure the chips are facing left and right , not up and down. They are very bright and might need adjusting. 

If you want a fool proof alternative, HID bulbs are great, but require you to have some what electrical knowledge to put them in if you are newer to cars because of the relay harness/ballists etc. 

 

Either one will greatly enhance the light output, just dont always go to cheap, you get what you pay for!

 

I went with Hikari brand led bulb because they use the Philips chips. mine, with canbus, were just over $100

I also bought led fog light bulbs, but went with an ebay bulb to test out

ordered led license plate lights and reverse lights, 

have a light bar coming in this week. 

 

Hoping to install it all this weekend. Will post pics to give a better idea when they are in!

Share this post


Link to post
Share on other sites

BdBerry,  Thank you for the info.  I have one question, what is a canbus?  I am good at doing swap outs, but when it comes to other high tech wiring/programming that brings me to a limit of reaching out to other folks for assistance.

Share this post


Link to post
Share on other sites
12 hours ago, martyman.geo said:

BdBerry,  Thank you for the info.  I have one question, what is a canbus?  I am good at doing swap outs, but when it comes to other high tech wiring/programming that brings me to a limit of reaching out to other folks for assistance.

 

Controller Area Network (CAN bus) is a robust vehicle bus standard designed to allow microcontrollers and devices to communicate with each other in applications without a host computer.

Share this post


Link to post
Share on other sites

JKeateon,  Thank you for explaining that.  I ordered a low beam set with the CANbus attached on the 14, they came in on the 28 and installed them this afternoon.  Don't look into the light after they are in.  Pretty darn bright in the daylight. 

 

I want to check them out at night to see the difference.  I did make sure the flat sides facing the sides not up and down.

Share this post


Link to post
Share on other sites

Hey all. New here. Just got a 2017 Journey GT. Got some new LED lights from cougar motors. Swapped out the halogen bulbs and they worked great. Shut the car off and started it again and they no longer work. Plugged the halogen back in and still nothing. I assume it’s a fuse. Just have to figure out which one. Do I need a larger fuse? Something I missed?

883CE100-2ABF-4662-947B-6F34DB14D871.jpeg

205F8475-C86C-4720-BE51-0E763B6ACED8.jpeg

52916416-A228-43A6-94C7-B3795797F212.MOV

Share this post


Link to post
Share on other sites

I had the same problem with LED lights. If you turn the car off and on again the halogens should come back on.

Share this post


Link to post
Share on other sites

Did you figure out the issue? I'm having the same problem!

Share this post


Link to post
Share on other sites
4 hours ago, Becks18 said:

Did you figure out the issue? I'm having the same problem!

 

What issue? Who are you asking??? 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×