Jump to content





JRaatz

Turns on by itself

Recommended Posts

Hi- So I have a 2012 dodge journey and my climate control will just turn on by itself as I am driving down the road. It will be off when i start the car and the once i start driving it is like an on/off war with the vehicle. I have all the back controls to the off position. Any suggestions on what to do. Was thinking something must be loose? 

Share this post


Link to post
Share on other sites

Had the same thing happen today. The rear controls just kept turning on. Every time I turned them off on the touch screen they would come back on. Finally reached back and turned the knob to the off position. Hopefully that is all for that.

Share this post


Link to post
Share on other sites

Well, not sure what could be causing this but try disconnecting the battery for 20mins or so.  This seems to fix electrial gremlins in the DJ.......

Share this post


Link to post
Share on other sites

Strange that this came up. I just got my steering column recall done and the next day my climate control started acting up. I always have it set to sync and for some reason I started her up and it wasn't on sync. Then as I was driving along, I realized my AC was on. I didn't remember turning it on. Finally, when I got in one time, the back fan was blowing on high. Yelled at the kids to turn it down, but they showed me out was on the lowest seeing. I thought it was me, since I was having a crazy week, but now I'm wondering. 

Share this post


Link to post
Share on other sites
On 9/2/2017 at 9:50 AM, OhareFred said:

Well, not sure what could be causing this but try disconnecting the battery for 20mins or so.  This seems to fix electrial gremlins in the DJ.......

Sorry Fred, just seeing this. I'll try this and let you all know how it goes.

Share this post


Link to post
Share on other sites

So I wanted to wait until this happened again before doing the battery move. Luckily it has not happened again, I remembered where the battery is and what a pain in the butt it would be trying to get to it.

Share this post


Link to post
Share on other sites

I may have figures it out. Was messing around with the back controls and have found out that one of the knobs is loose. Can just touch it and it turns system on. Will have to see if that knob is replaceable. it is the temperature knob.

Share this post


Link to post
Share on other sites

I will have to check mine to make sure this isn't the culprit. Thanks.

Share this post


Link to post
Share on other sites

This is recently occurring on my 2012 SXT. When it first started I would just lock the rear controls out so that it would stop breaking sync.

I took it on a road trip this weekend and the rear passengers wanted to use it though. A few days into the trip and suddenly it's blowing hot air in the back.
I decided to lock the rear controls out again, but when I went to the screen to do it the temp slider was flying up and down like crazy without anyone touching the knobs.
I wound up waiting for it to slide down to cold and pressing lock just as it hit the bottom. It's been left alone since. I'm curious if it's a problem with that control panel, or the HVAC system itself.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×