Jump to content





Recommended Posts

Hiya,

I am reading the from for a quite while but this is my first post

I live in Turkey and using dodge journey 2012 (fiat freemont in europe) 2.0 diesel engine with 62te 6 gear transmission , lounge (equivalent to sxt)

car itself has the alpine sound system, my dash speakers are not working. we have 2 of this car and when ı tried the amplifier from the 2nd car , didn't help either. so I decided problem is speakers not the amplifier. all the other speakers are working only there is no sound from the dash speakers.

anyone else had a problem like this before?  I wanted to remove and try other speakers on dash but couldn't find how to remove dash speakers, it seems there is no seperate cover , do I need to take out all dash? that's crazy :)

 

 

Share this post


Link to post
Share on other sites

How do you know it even has dash speakers? Maybe you don’t and that’s why they are not working. 

Share this post


Link to post
Share on other sites

hi there,

i have dash speakers since these cars imported only in 1 package to Turkey and all of them are same. we have 2 of these cars

and since front door subwoofers are working we have only sub sound on the front no mid or treble, we need to use fader to use the speakers on the back to be able to get a normal sound.

any idea why not they don't work or how to remove those grills?

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×