Jump to content





Sign in to follow this  
djrt13

UConnect Bluetooth and Handsfree Stuck on Please Wait...

Recommended Posts

Hi!

 

I currently own a 2013 Dodge Journey RT. As of late, I have been having issues with both the Bluetooth and the Handsfree functionality of the vehicle. They are completely non-functional. Each time I try to use them, I'm met with a Please wait... message from UConnect.

 

I've read here on the forums that I should first try disconnecting the negative terminal of the battery for a period of time in attempt to reset the computer. However, after locating the negative terminal under the hood, I've been unable to disconnect it due to a plastic barrier around the nut. Here's a picture I found of it. Frankly, I have no idea how to remove this barrier, and the isolation hole shown here as item #3 doesn't seem to have a purpose. Just to add, I brought the vehicle in to be assessed, but after a $200 CAD assessment, they told me it would be $700 CAD to fix. 

GUID-08-051-001-92732.jpg

I can find the MOPAR part online for much cheaper, and I'm tempted to buy it and have my local mechanic install it. That being said, I just want give this potentially simple fix a chance before I fork out the cash. Am I missing something here to disconnect the terminal and battery? Any help would be much appreciated!

Share this post


Link to post
Share on other sites

I had that message and ended needing a new module the battery disconnect didnt help

Share this post


Link to post
Share on other sites

On my 09 you need a 10mm (pretty sure it was) socket to remove the nut.  The plastic/rubber barrier is  part of the cable and does not come off.

Share this post


Link to post
Share on other sites

On  my dodge Journey 2011 the negative battery needs a 15mm socket but a 15mm universal socket didn't work. 

 

I'm facing the same issue, Bluetooth is not working anymore, when I press the button on the steering Wheel it does Nothing, press the "phone" icon on the uconnect 8.4 doesn't do anything either and now I can't set Bluetooth in the music player since it is not even an option anymore .... Guess my module is shot :(

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×