Jump to content





Recommended Posts

Finally made the decision to redo my stereo. May have gone a lil bit overboard but hay what's the worst that can happen lol.

Still need to finishing tuning stereo and building trim piece to wall it off but so far sounding good. 

 

2 Rockford Fosgate P3D4 15s

2 Rockford Fosgate P3D4 12s

4 Alpine 6x9s

2 Kicker 3.5s in dash

Soundstream Tarantula T1.6000DL 

Subs wired in parallel to 0.5 ohms

WestCoast Customs WCC1500.1 mono amp made by MB Quart for 2 door speakers to be added later

WestCoast Customs WCC1600.4 4 channel amp running to 6x9s in doors

Kenwood DDX774BT Double Din head unit

XS Power D925 battery

1/0 wire wire

 

2h6dnd0.jpg

 

296f9qp.jpg

 

Reason i decided on running both 12s and 15 is to have a wider range in frequencies.

Share this post


Link to post
Share on other sites

Hope that's bolted down......wouldn't want them hitting me in the back of the head lol.

Share this post


Link to post
Share on other sites
24 minutes ago, Junior102 said:

Hope that's bolted down......wouldn't want them hitting me in the back of the head lol.

 

Lol they're bolted all together. Dont move much. And with the back seats up there isnt enough room to make it to me.

Share this post


Link to post
Share on other sites
38 minutes ago, onecrazyfoo4u said:

Wow, that's some serious wattage!  How's the stock battery and alternator handling that?

 

With the second battery it oddly handles it just fine. Down the road I will upgrade alt but for now it works

Edited by Locosiete

Share this post


Link to post
Share on other sites

Got a mehman 240 amp alt. Now just waiting for the freezing cold to pass!

Share this post


Link to post
Share on other sites

Well thought i would post since i am on. Been offline for some time. 

Several months ago someone decided that i no longer needed or wanted my system. 

Luckily for me my amps were out since i was redoing the amp wires. Was going to relocate so they would have more air. Oddly they didn't take deck, not that i am complaining!!

 

So have redone my system again. This time i may have gone a bit more overboard.

 

2 15" Fi Audio BTL Neo's

have each one wired to 2500 watts RMS at 1 ohm. 

had this box custom made and it ain't going anywhere without some major cutting.

Share this post


Link to post
Share on other sites

Must be in California where everyone thinks whatever someone else has is theirs.....  ;)

Share this post


Link to post
Share on other sites
6 hours ago, Locosiete said:

Well thought i would post since i am on. Been offline for some time. 

Several months ago someone decided that i no longer needed or wanted my system. 

Luckily for me my amps were out since i was redoing the amp wires. Was going to relocate so they would have more air. Oddly they didn't take deck, not that i am complaining!!

 

So have redone my system again. This time i may have gone a bit more overboard.

 

2 15" Fi Audio BTL Neo's

have each one wired to 2500 watts RMS at 1 ohm. 

had this box custom made and it ain't going anywhere without some major cutting.

I bet it sounds good! One a side note though, do you think maybe you are having electrical issues because of the power drawn? I have 0 experience when it comes to stereo upgrades but based on the issue you said you were having in your other post it may be related to your system. Or I could just be completely wrong, just an idea ;-) 

Share this post


Link to post
Share on other sites
16 minutes ago, jkeaton said:

Must be in California where everyone thinks whatever someone else has is theirs.....  ;)

 

Nope here in the northwest in Washington State. In my area is for the most part crime free. Had a new neighbor and things started to disappear randomly. He moved away. Month ago and nothing since... Hmm gee coincidence?!? Lol

 

10 minutes ago, lmoore1436 said:

I bet it sounds good! One a side note though, do you think maybe you are having electrical issues because of the power drawn? I have 0 experience when it comes to stereo upgrades but based on the issue you said you were having in your other post it may be related to your system. Or I could just be completely wrong, just an idea ;-) 

 

Don't usually have stereo volume higher then a soft conversation. More of a background noise for our daily commute. My wife HATES loud music and since we carpool it's usually turned down. I have upgraded all the electrical so i know that's not the issue. Where i am at if i didn't or went too small it would have melted a wire by now or started a fire. And the any wires effected would be part of the charging system.

 

was able to connect my OBD2 reader this morning, son had Subaru it was in last night, and gave me codes for ECU for SRS and fuel gauge. But not for the service AWD. Drove it a bit this morning and check engine light came on right away and the traction control light stays lite, forgot to mention that one before, but no codes for it.

Share this post


Link to post
Share on other sites

Well issue before codes no longer coming on but well see if it stays that way.

 

Finally installed my Mechman alternator that is 247amps at 2000 rpms. Definitely helps!

completee my big 3, just need to make another run from battery in front to rear battery.

 

20180612_123108.thumb.jpg.39ec0c957beec48c19c6c868b6d4136c.jpg

Share this post


Link to post
Share on other sites

New Mechman alt with smaller pully

 

PSX_20180613_140708.thumb.jpg.6e7a514c530cb89029d4edde26122e29.jpgPSX_20180613_140643.thumb.jpg.d571fe62ab2a3e48a4f3c6336908fd9a.jpg

 

 

 

 

Share this post


Link to post
Share on other sites
3 hours ago, redtomatoman said:

Post some interior pics.  Curious to see what is in place of the controls.

 

peace. 

Thought i did before. Oops lol!

 

Intial install before painting trim to match

PSX_20180613_224534.thumb.jpg.e4f2732e8926ca25eaa0d92923436f80.jpg

 

After painting to match

 

PSX_20180613_224642.thumb.jpg.8e1052801b938137386029c9c8a795e8.jpg

Share this post


Link to post
Share on other sites
18 minutes ago, redtomatoman said:

Wow.  Looks great.  That's professional, man.  Good job.  

 

peace.

 

Thanks. While i am at it here is the new system

 

PSX_20180613_224224.thumb.jpg.32bb299dccdb860b0881b8f47c34ad2f.jpgPSX_20180613_223944.thumb.jpg.30861eef254494d1f6879efe5a5eaf4e.jpgPSX_20180613_224047.thumb.jpg.8731b903ccf642689f49abab929e43d5.jpgPSX_20180613_224105.thumb.jpg.930ceb0c14e08a2b443e840a862ca086.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×