Jump to content





Sign in to follow this  
StartingToHateMyJourney

Hello from Atlanta

Recommended Posts

2012 Journey with 145K miles on it. 

First the radio comes on full blast when I start the car, but only occasionally.  Went to the dealer and there was going to be some ridiculous charge for the evaluation, figured I could live with it.  Now occasionally will come on, the screen lights up, I can change stations, but no sound, stopping the car, shutting the car off, opening the door, closing the door, starting the car up again seems to reset the radio.

Now the front climate control blower occasionally won't come on, and sometimes when it is working, the fan controller doesn't set the fan at the proper speed, seems to be bogged down from time to time.  The rear climate control works fine.

And lastly, from time to time when I start the car, put it into drive, it will not shift out of first gear. Trying to manually shift it does nothing, stays in first.  I have to pull over, shut the car off, restart it and it drives fine.  

All of my car savvy friends are telling me that I probably need the onboard computer updated.  What are your thoughts? 

Edited by StartingToHateMyJourney
Greeting

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×