Jump to content





Crystal Stewart Chandler

Check engine light, Electronic Throttle Control & Electronic Stability Control Off

Recommended Posts

I purchased my 2013 Dodge Journey in July of 2013. Since then I have had check engine lights coming on 6 times. First time was only a couple months after I purchased it and less than 1500 miles and then 2-3 other times during the next months. Dealership that i purchased the vehicle from has replaced sensors, replaced main computer board that the errors are sent to.

After speaking with other dodge owners decided to take to another dealership. Very friendly and said that the problem is the computer needed an update and that was why I was getting the check engine light messages. Since I have been taking it to them have not had anymore problems until yesterday 10/21/14. When I leave work and start car the check engine light, electronic throttle control and electronic stability control off lights come on. Car is not running right. Try to drive and it is hesitate when i press the gas petal. After shutting car off and back on several times car starts running better and only the check engine light is on. Stop several places before I head home and when I start the car on the way home the check engine light is off and was still off when I come to work this morning.

One thing I have noticed when all 3 lights come....It has been cold on the morning 7-8 am drive to work 30-40 degrees, I don't drive again until on my way home which is 5 pm and temperature has warmed up to around 75 degrees.

I am once again calling dealership to take car in to get looked at but I am very frustrated.

Share this post


Link to post
Share on other sites

Dont know what to tell you other than if you can get the codes and post them here, we might be able to help you more. Good luck and welcome to the forum!

Share this post


Link to post
Share on other sites

I purchased my 2013 Dodge Journey in July of 2013. Since then I have had check engine lights coming on 6 times. First time was only a couple months after I purchased it and less than 1500 miles and then 2-3 other times during the next months. Dealership that i purchased the vehicle from has replaced sensors, replaced main computer board that the errors are sent to.

After speaking with other dodge owners decided to take to another dealership. Very friendly and said that the problem is the computer needed an update and that was why I was getting the check engine light messages. Since I have been taking it to them have not had anymore problems until yesterday 10/21/14. When I leave work and start car the check engine light, electronic throttle control and electronic stability control off lights come on. Car is not running right. Try to drive and it is hesitate when i press the gas petal. After shutting car off and back on several times car starts running better and only the check engine light is on. Stop several places before I head home and when I start the car on the way home the check engine light is off and was still off when I come to work this morning.

One thing I have noticed when all 3 lights come....It has been cold on the morning 7-8 am drive to work 30-40 degrees, I don't drive again until on my way home which is 5 pm and temperature has warmed up to around 75 degrees.

I am once again calling dealership to take car in to get looked at but I am very frustrated.

I am sorry to hear you are experiencing an issue with the check engine light. Please keep us posted once the dealer diagnoses the issue.

Share this post


Link to post
Share on other sites

Hello,

My 2013 Journey SE Plus has started experiencing this exact same problem. It started over the last few weeks as a small power loss for a second or so while accelerating every once in a while. It has been good for the last week or so and starting last night things got worse.

Now most of the time while accelerating once the engine RPMs are between 2K and 3K the RPMs will suddenly drop to around 2K, the engine will start surging, the ETC and Trac lights will come on and Trac light won't turn off until I shut the vehicle off. The ETC light will go away once the RPMs come back up.

I have read online about others having a similar issue and the Electronic Thottle body needed to be replaced. Right now I have 92K on it and does anyone know if this were to be the issue would it be covered under the powertrain warranty? I haven't called the dealership yet because it is Sunday and they are not open.

Thanks!

Share this post


Link to post
Share on other sites

The other thing I forgot to mention is that over the last few weeks during the really cold mornings when I use the engine block heater the engine will idle very low (around 500K) and very rough for about 30 seconds, then the RPMs will come up and everything will smooth out.

Share this post


Link to post
Share on other sites

Unfortunately no, it never did come on and my scanner didn't bring up any error codes either.

Share this post


Link to post
Share on other sites

Just an update... I took the Journey to the dealership and there were codes stored in the computer indicating that the computer was limiting engine RPM's because the Electronic Throttle Body was sticking.

They replaced the Throttle Body and the problem has been resolved.

Share this post


Link to post
Share on other sites

Tnx for reporting problem and resolution , that's the way the knowledge base grows.

Share this post


Link to post
Share on other sites

Just an update... I took the Journey to the dealership and there were codes stored in the computer indicating that the computer was limiting engine RPM's because the Electronic Throttle Body was sticking.

They replaced the Throttle Body and the problem has been resolved.

klingoff,

Happy to hear everything was sorted out, thanks for posting the details.

As bigtsr mentioned, it grows the knowledge base for other members and may one day be the fix they are needing.

Thanks again! :lol:

Share this post


Link to post
Share on other sites
On 3/28/2015 at 10:31 AM, klingoff said:

Just an update... I took the Journey to the dealership and there were codes stored in the computer indicating that the computer was limiting engine RPM's because the Electronic Throttle Body was sticking.

They replaced the Throttle Body and the problem has been resolved.

Do you remember how much this cost

Share this post


Link to post
Share on other sites
3 hours ago, Guajardo Family said:

Do you remember how much this cost

 

Under warranty = $0.

Out of warranty = @$1000

Share this post


Link to post
Share on other sites
1 hour ago, jkeaton said:

 

Under warranty = $0.

Out of warranty = @$1000

you could try cleaning it first, couldn't hurt......

Share this post


Link to post
Share on other sites

Good Day,

 

It has been a while since I was on this forum.  Unfortunately I don't recall exactly how much it was.  I remember at that time the part was under $500 and the dealership covered the labour under their "Good Will" warranty.  I am not sure exactly how that works so it may not apply to everyone.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×