Jump to content





jwkwak3

Star Case Entered For Camshaft Position MIL and Traction Control Light

Recommended Posts

Long story short my 2011 Mainstreet has been in the shop twice for the check engine light and traction control light coming on at the same time. The dealership techs states that after everything they cannot see anything that is causing the issue so they have opened a star case with Chrysler. Does anyone have a general idea of how it will take Chrysler to respond? Also has anyone else had this problem?

Share this post


Link to post
Share on other sites

Talked to the dealership yesterday and they stated they have not heard anything and that they do not know when they will as they cannot talk to a live person everything is done via a computer. That sounds weird.

Share this post


Link to post
Share on other sites

Just heard back replacing all four phasers. I hope this will be the end of the current issue.

Share this post


Link to post
Share on other sites
On 6/28/2019 at 10:13 AM, jwkwak3 said:

Just heard back replacing all four phasers. I hope this will be the end of the current issue.

 

Hi jwkwak3,

 

We’re sorry to hear of the trouble you are experiencing with your Journey. We would like to have this documented and have a case escalated in your behalf so a Case Specialist can work with your dealer to help find a potential solution. Please follow up with us via private message if this would be of interest.

 

Mark

Dodge Social Care Specialist

Share this post


Link to post
Share on other sites

Well got the car back Monday evening and all seemed good until just a few minutes ago. My wife called and stated the MIL was on and the traction control was also on. Also stated car had no power like usual when the lights first illuminate. The car has been in the shop almost three weeks and now its going to have to go back for the same issue.

Share this post


Link to post
Share on other sites

So I thought I would share all the codes with everyone. As I get more information I will gladly share in case others experience the same issue. The active codes are P0340, P0365, P0390, P0345, C121C00. These are the sames as the last time before the suggested repair. I am thinking that the C121C00 code is causing most of the issues but I cannot be 100% percent positive. The repair was the camshaft phasers replaced on front and rear banks, VVT solenoid O-ring and other gaskets removed during the process.

Share this post


Link to post
Share on other sites
On 7/10/2019 at 10:05 AM, jwkwak3 said:

Well got the car back Monday evening and all seemed good until just a few minutes ago. My wife called and stated the MIL was on and the traction control was also on. Also stated car had no power like usual when the lights first illuminate. The car has been in the shop almost three weeks and now its going to have to go back for the same issue.

 

Hi jwkwak3,

 

Sorry to hear that you are still experiencing these concerns after getting your Journey back. As previously stated, we would be more than happy to escalate a case on your behalf so a Case Specialist can work alongside your dealer. We’re just a private message away.

 

Mark
Dodge Social Care Specialist 
 

Share this post


Link to post
Share on other sites

Update:  Car is back from the dealership and we have put about 300 trouble free miles on the car. The last issue were the camshaft Position Senors so it seems we are good to go. My wife is very happy to have her car back and running great.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×