Jump to content





Recommended Posts

Hi everyone I just got this 09 Journey 3.5l a week ago and the previous owner has it rigged up to run the fan by connecting a wire to the positive battery terminal. it looks like this unknown wire connector was damaged so they rigged it up to work. The fan works fine when it is connected.  I really need to know what this connects too and can I buy a connecter to splice in and replace this bad one?

Thank you for any and all advice.

IMG_20190531_102703_1.jpg

Edited by captandave
misspelled a word

Share this post


Link to post
Share on other sites

So no one knows where this connects?  it runs fine just I don't like having to connect the fan to the battery Everytime I drive it.

Share this post


Link to post
Share on other sites

It’s obviously some kind of Mickey Mouse repair by the previous owner.  That blue connector looks like it’s for a relay. Don’t think my 09 has anything like that.  Your looking at it, start by following the wires.  You’ll have to open the wire loom to see where it goes. Look for melted, blackened, or cut wires.  Hard to say what’s what going on  by a picture. The attempted repair was done because someone else didn’t want to do the job right.

Edited by OhareFred

Share this post


Link to post
Share on other sites

Thank you for responding. yes it's really a hoky repair. She said it goes into a fuse box which needs replacing but I don't think that is close to right. I could by pass this connector using wires with female connectors but I still need to know where or what it connects to.  I may go look at a used journeys engine to see if I can figure it out. 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×