Jump to content





Nicola

Aftermarket rear camera has vertical lines, and will not shut off.

Recommended Posts

I have had a garage install the wired GCH BUCAM 1 rear and front cameras for the 4.3" screen on my 2017 Journey SXT.  After 1.5 years of excellent service, suddenly, the Rear Camera does not shut off after the 20 seconds maximum time ON.  Too, there are multiple (around 20) vertical lines on the screen.  Shutting the engine and re-starting brings the same on the screen.   Any ideas as to what is wrong ?  Thanks.

Share this post


Link to post
Share on other sites

Cameras going bad maybe? Hard to tell over the internet.

Share this post


Link to post
Share on other sites

yep probally going bad,time to replace it,i had the mopar oem added to my 14 crossroad.

Share this post


Link to post
Share on other sites
On 3/4/2019 at 11:58 PM, Nicola said:

I have had a garage install the wired GCH BUCAM 1 rear and front cameras for the 4.3" screen on my 2017 Journey SXT.  After 1.5 years of excellent service, suddenly, the Rear Camera does not shut off after the 20 seconds maximum time ON.  Too, there are multiple (around 20) vertical lines on the screen.  Shutting the engine and re-starting brings the same on the screen.   Any ideas as to what is wrong ?  Thanks.

 

from a short google looks like they dont sell them no more good luck

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×