Jump to content





lmsplus4

New battery, good Alternator, car shuts off.

Recommended Posts

Approx 3 weeks ago battery saver light came on while driving home. All warning lights came on shortly after (20minutes)into drive. Car started losing gear. Made it home. Had alternator checked by two different places. Says its fine. Had battery replaced. Was ok for one day then it happened again after sitting overnight. Currently waiting for tow as it wont start after picking kids up from school. (2min trip). What is wrong???? Any ideas would be helpful. 

Share this post


Link to post
Share on other sites

Reads like you have electrical issues...what type of drivetrain? is it a Journey?

Could be one of many components that is causing this I would get someone who knows what they're doing to diagnose it  

Share this post


Link to post
Share on other sites
1 hour ago, lmsplus4 said:

Yes it's a 2011 dodge journey awd. 

i would have the new battery LOAD tested to make sure it is good. hope they tightened the cables down tight on the battery also. what do you mean the car was losing gear?

Share this post


Link to post
Share on other sites

Start at the source and work your way from the stove it could be multiple items as Larryl mentions. 

- Have the battery tested

- Make sure cable are nice and tight, and clean

- Make sure the ground is connected securely to a clean metal surface

- Test alternator (looks like that's done) 

- Check starter... don't know if the car didn't turn over or was just plain dead

From there you need to get fuses and relays checked. Then an experienced electrical shop. Good luck. 

Share this post


Link to post
Share on other sites
3 hours ago, lmsplus4 said:

When it was battery saver mode it will only stay in one gear. 

no such thing as battery saver mode, the transmission has the limp home mode when there is a problem with the transmission...

Share this post


Link to post
Share on other sites

^^^  this.

 

I have had very few probs with my 2011, but recently I had a total transmission failure.  I had a check engine light and no other symptoms that I could tell.   Dunno.  Get it checked if you think the tranny may be the culprit here...

 

Peace.  

Share this post


Link to post
Share on other sites
On 12/10/2018 at 4:01 PM, lmsplus4 said:

Approx 3 weeks ago battery saver light came on while driving home. All warning lights came on shortly after (20minutes)into drive. Car started losing gear. Made it home. Had alternator checked by two different places. Says its fine. Had battery replaced. Was ok for one day then it happened again after sitting overnight. Currently waiting for tow as it wont start after picking kids up from school. (2min trip). What is wrong???? Any ideas would be helpful. 

 

Hi lmsplus4,

We're very sorry that you are experiencing this difficulty. Please let us know if you plan to have your dealer look into this. Just send us a private message and we will gladly assist you while you vehicle is at the dealer.

Lydia

Dodge Social Care Specialist  

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×