Jump to content





Recommended Posts

I have a 2016 dodge journey R/T with another issue. So as of 03/31/18 I began to have a issue with my heated seats driver side stays on which as you can imagine is not ideal. This happens regardless of auto start or manual start. I did the reset has not worked. The steering wheel warmer does not work also I can not select it on the controls, only screen off and outlet power work. I drove more than a hour in the car and seat warmer just stay on and it stays on hi. Doesn't show which is selected but it hot as a mofo, so I imagine it's high.

Share this post


Link to post
Share on other sites

well since no mention of miles i will assume no warranty is left, you could always pull the fuse for the seats till you can get it looked at...good luck

Share this post


Link to post
Share on other sites

I pulled the fuse out but it seems that I'm the only person with this problem and vehicle is 54k in and uconnect offers no damn help with their junk. Not my first issue, experienced Bluetooth issues n had to reset it, seems uconnect doesn't want to accept the fact their units are defective. Wish it would have had physical buttons to cancel out what could be the issue.

Share this post


Link to post
Share on other sites

No warranty. But I'm dieing to see if someone else has had this problem. Seems like I'm the first 1 can't find this issue with any1 else. I've seen the issue where people's heated seats turn off intermediately but mine won turn off on driver side and passenger doesn't turn on and steering wheel. The blonde screen buttons don't work. @larryl

 

Share this post


Link to post
Share on other sites

my journey came with no heated seats so we had them added after market as the dealers didnt want to do it, so we have a 2 way switch that is located in the plastic side seat panel , easiest fix for you would be to add such a switch to yours. problem fixed for probably less than $10. if you do it your self.....that is what i would do.......good luck

Share this post


Link to post
Share on other sites

Sucks I got this issue upon others ucconect is no help and that fix only fixes my heated seat not steering wheel. Sucks dodge didn't add a physical button. Called uconnect they were even stumped and even if it's defective they will do nothing about it. They got their money they don't give a crap. 

Edited by jkeaton
no need for vulgarity

Share this post


Link to post
Share on other sites

well since this does seam to be a rare problem i dont see how you can blame the manufacture as things do tend to break down or not work as expected ,sorry you are having this problem. guess its time to do what most of have to do .put it in for repair at the dealership and hope for the best.....good luck on what ever you do.

Share this post


Link to post
Share on other sites

Out of warranty sucks when things go wrong. Calling uconnect wont fix it. lol. 

Edited by jkeaton

Share this post


Link to post
Share on other sites

I've got told 2 things by friends. The switch and body module might need to be programmed. Just another issue for me to reconsider ever buying another dodge. I'll go Honda or Mitsubishi on my next purchase owned both brands in the past and never a issue stick to what you know right. Hopefully this junk gets recalled. I've seen many post about uconnect releasing this with known issues. Best part I was told being I'm the 2nd owner (used car) warranty doesn't transfer to next owner. I'ma just wait summer is here hopefully someone ends up finding a fix for the issue. Thanks for all the reply.

Share this post


Link to post
Share on other sites
28 minutes ago, DizzyR/T said:

I've got told 2 things by friends. The switch and body module might need to be programmed. Just another issue for me to reconsider ever buying another dodge. I'll go Honda or Mitsubishi on my next purchase owned both brands in the past and never a issue stick to what you know right. Hopefully this junk gets recalled. I've seen many post about uconnect releasing this with known issues. Best part I was told being I'm the 2nd owner (used car) warranty doesn't transfer to next owner. I'ma just wait summer is here hopefully someone ends up finding a fix for the issue. Thanks for all the reply.

Well since it is causing an issue with both heated seats and the steering wheel I would say that it is probably something wrong with the head unit itself, or the wiring. How many miles are on the DJ? The manufacturers warranty is transferable if you are within the 36k, and up until that point you can also purchase the mopar extended warranty. As far as Honda and Mitsubishi, I'm sure you realize that technology has made mostly all vehicles infinitely more complicated. My 2016 civic cruise control wouldn't work because of a bad sensor on one of the wheels and it took 4 trips to the dealer to figure that one out. Mitsubishi is basically a shell of the company it used to be so I wouldn't put too much faith in them either, they're cheap but it seems like they've been struggling for a while. 

Share this post


Link to post
Share on other sites
1 hour ago, DizzyR/T said:

I've got told 2 things by friends. The switch and body module might need to be programmed. Just another issue for me to reconsider ever buying another dodge. I'll go Honda or Mitsubishi on my next purchase owned both brands in the past and never a issue stick to what you know right. Hopefully this junk gets recalled. I've seen many post about uconnect releasing this with known issues. Best part I was told being I'm the 2nd owner (used car) warranty doesn't transfer to next owner. I'ma just wait summer is here hopefully someone ends up finding a fix for the issue. Thanks for all the reply.

as IMoore stated if your still in warranty yrs and miles you WOULD be covered even if your the 7th owner i guess who ever told you that  it wasn't the dealership, so much for second hand advice.....and every manufacture has problems and glitches and since cars are getting so much more complicated with computers and software and also dealerships not able to catch up to all the new technology, there will always be problems and such.

Share this post


Link to post
Share on other sites

What is this box under driver seat this box kept falling and now it's a lil dented wonder if this is my problem anyone know what this is?

Snapchat-488434981.jpg

Share this post


Link to post
Share on other sites

13 14 15 16 2013-2016 Dodge Ram 1500 Truck Towing Chassis Control Unit Module is what comes up on e bay for the part #64469s took me about 4 minutes with google to find this.....

 

Share this post


Link to post
Share on other sites
9 hours ago, 2late4u said:

13 14 15 16 2013-2016 Dodge Ram 1500 Truck Towing Chassis Control Unit Module is what comes up on e bay for the part #64469s took me about 4 minutes with google to find this.....

 

 

4  minutes of your life you will never get back......;)

Share this post


Link to post
Share on other sites

Ok I thought that was the issue since it was slightly dented. Been driving most ofthe day. Also the box of hot to the touch uncomfortably hot thought I hit jackpot on my problem. I'm going to see if I locate the module for the heated seat pull it out and bring it to my buddy see if it's damaged. 

Share this post


Link to post
Share on other sites

So I had it pulled out the car metal was touching the mother board inside. Reshaped it but it might be done. Couldn't tell if anything was shorted out. Found out it's not for the towing chasis control unit. Apparently I shouldnt have any parts from ram in the journey. Now to figure out if I order 1 when I got time and money to spare cuz summer here I don't need it. But I'm trying to fix it as soon as I can. I looked up the part and keep seeing the freemount (Fiat version) of this part. 

Share this post


Link to post
Share on other sites

Ok so this is my problem who ever designed this is not the smartest person. This box is mounted right under the seat and the yellow foam is the only protection they provided. You can see the board is burnt from the metal touching it. Funny part is this was one of my issues months back when I got the car. Wires are too short to relocate the box, the box always fell out. Design flaw. I think so.

 

IMG_20180412_161935.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×