Jump to content

Search the Community

Showing results for tags 'battery'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Dodge Journey Community
    • Welcome!
    • Forum Help and Suggestions
  • Dodge Journey Social
    • Articles, News & Reviews
    • Buying, Leasing, Ordering & Competing Products
    • Lounge
    • Owner Impressions
    • Photos & Videos
    • Super News Ticker
    • Facebook @ Dodge Journey Forum
  • Dodge Journey Modifications & Technical Forum
    • Accessories, Modifications
    • Alarms, Keyless Entry, Key Fobs, Locks & Remote Start
    • Appearance
    • Audio, Infotainment Navigation, MyGig, UConnect, etc.
    • Brake, Chassis & Suspension
    • Climate Control
    • Electrical, Battery & Charging
    • Engine & Driveline
    • Exterior & Body
    • Glass, Lighting, Mirrors, Sun Roofs & Wipers
    • Hauling & Towing
    • Interior
    • Service
    • Wheels & Tires
  • Dodge Journey Classifieds
    • Classifieds
  • Dodge Journey Testing
    • Test Forum

Marker Groups

  • Members

Found 16 results

  1. Approx 3 weeks ago battery saver light came on while driving home. All warning lights came on shortly after (20minutes)into drive. Car started losing gear. Made it home. Had alternator checked by two different places. Says its fine. Had battery replaced. Was ok for one day then it happened again after sitting overnight. Currently waiting for tow as it wont start after picking kids up from school. (2min trip). What is wrong???? Any ideas would be helpful.
  2. Concise version: Car sits outdoors for 2 weeks. Temps outside are 32F. No electric power, no unlock, no dome lights, obviously no cranking power. 1) Ask for jump, successfully cranked the car. All systems running normal while connected to the jumper's car's power. 2) disconnect jumpers after about 30 seconds. 3) 15 seconds of normal operation, then overhead lights pulse on-off-on-off twice a second, radio on off, some warning lights on-off (mainly traction control, tire pressure) then engine stalls- zero electric power (dome lights dead), and tachometer is stuck at last reading 1,500 RPM (What i was Reving-to hoping to keep the power flowing, stepper motors didn't have power to return the tach to zero). 4) jump again. instantly, on jumper's power, gauges return to zero, and the car systems are restored to normal operation while on jumper. Crank engine, starts no issue. All systems normal. 5) removed jumpers, systems function properly for 15 seconds, then same as before, pulsing overhead lights, some lights on dash, 15 more seconds the engine stalls, tach and fuel gauge frozen (steppers without power) my troubleshooting: voltage at the under-hood battery mains while connected to the car: 0.3v. I disconnect the negative terminal here, and test the the neg-to-pos voltage: 3.4v. Note, battery is 3 months old. Hypothisis: 1) Terminals corroded (I'll freeze my butt off, but i'll check this next) 2) Bad battery temp sensor. No idea how to diagnose. 3) Bad Alternator (and dead/depleted batt.) Coming home from my wonderful tropical vacation to see my Wife in Brazil, I get home and rush to get to work the same day... only to call in an tell them my dodge wouldn't start. I work at GM, so they gave me a hard time, but understood that as I am driving a FCA product, there is an understanding that occasionally it won't work. Any suggestions? (other than abandoning the car and flying back to Brazil permanently?) I'll update when It's fixed
  3. Dodge Journey RT 2010, I have replaced, alternator, battery, starter, we had the battery grounded with additional cable. The car will not hold a charge. What is the quickest way to get to the issue. I have read Blue Tooth may be draining the system. Please advise.
  4. So my car won't start. things that have happened 1. wouldn't start but after a boost it would be fine for few days. 2. Changed battery, lasted few days then needed a boost again. 3. Took to mechanic, changed out the alternator. 4. Next day car is going crazy lights off and radio off and on. I take it back. Turns out wrong alternator was bought. Switched out for proper one. 5. Started happening again. But not right away. Took it to work. Started going crazy again. See attached to see what it's doing. http://sendvid.com/fyd4o133 6. After driving with it doing this. Now car won't start at all. left battery boosting for 30mins. Nothing. Once I disconnect booster cables. Car lights go out. planning to check the battery connections tomorrow and make taking the battery out to make sure it's all good. Any other ideas to get car started at least? when trying to start it only gives a little click and small try to turn but not enough. Also noticed the lightning bolt is lite up now.
  5. Replaced the alternator on my 2012 Dodge Journey SXT, new battery, and vehicle now is showing no power whatsoever. Don't know what else to try, really in need of help with this.
  6. Has anybody had their Journey not start and had to have it jump started. My 2015 only has 4600 miles on it, (7 months old).Went to start it after 2 days sitting in my driveway and it would not start. Called Roadside Assist, had it jump started and off to the dealership. They charged the battery for 1 hour as per their protocol and it passed. They advised they checked the anti run-down and it was also working. I brought it home turned it off and even left the rear hatch unlocked and only closed it (not completely locking it) All the interior lights turned off including the large one in the rear tailgate after a couple of min's. Its the Limited model and the headlights are set for Auto and the Key fob was not left in the vehicle either which I understand might cause the computer to think I am still in the vehicle and ready to start it again which might cause a battery drain. ????
  7. The car will not unlock, no dash lights, headlights, no key not detected signal, but brake lights work. changed battery For the fob 6-7 months ago. Car battery was replaced 5 months ago. A mechanic came out and said battery looks fine. I do not know what to do my car has been sitting at work for three days now.
  8. musicdj

    2012 journey, while driving it went dead. had it jumped went about 30 miles and it died again. got it going, and just before it died again the battery light came on. at first I just figured the alternator no good, but I noticed the rpm's were higher than normal. can it be the alternator is over charging. got new battery same thing. no other lights have gone on thanks.
  9. I've been having issues starting my 2010 Journey (2WD 6 cyl, 3.5 L, Automatic 6-spd) and I'm convinced it may be a bad starter. I replaced the battery in January and just replaced the alternator a few days ago after my car would not start and a horrible smell permeated through the vents when attempting to start multiple times. New alternator is in and now when I turn the key to attempt to start the engine, I get nothing, no sounds whatsoever. Lights are on and do not dim when attempting to start. Can anyone advise where exactly the starter is located? I have not been able to find the location of the starter and have not found any indication of where it may be online. Any help would be much appreciated. Pictures of starter location would be even better.
  10. Greetings... I was told by a local garage mechanic NOT to use a battery tester on my 2014 Journey. He said it would damage the electrical system and computer. I've been using an inexpensive 100 amp battery load tester from Harbor Freight on my older Chrysler products with no problem. I'm mainly interested in the 'Cold Cranking Amps' up here in snow country. Got any opinions about using it on my Journey...??? Thanks >> (My tester is the type that heats up a coil until it glows like a toaster.) Roger >>
  11. I have a 2009 Dodge Journey R/T, and everything was working fine until one day I noticed that occasionally while driving the stereo and navigation system display would get all distorted and then lose power completely. A couple minutes later however it would power on again. A few days later I went to start the vehicle (and it had been running earlier that day) and it would not start. It just made a clicking sound as if the battery had been drained. I used another vehicle with jumper cables to start it, and it fired up right away. However, in order to keep it running I had to press on the gas to keep the engine rpm up to at least 2000 rpm or so. If I left it to idle, the battery warning light symbol would come on, and all the other warning lights would light up just as they do when you turn the key on before starting the engine. Pressing on the gas a bit would make these lights go off as well as the battery one. If left to idle any longer the engine would just die after a couple of minutes. I thought it might have been the battery causing the problems so I put a charger on it for a while and was still unable to start the vehicle. I removed the battery, charged it up and used a tester on it. It is rated for 640 CCA and tested at 590 and at a voltage of 12.9 V. The tester indicated that the battery was good. When I tried using a different vehicle jumpered on to the battery connections of this vehicle, It would not start it either. The dash lights would light up when connected and the power locks would make a sound like they were trying to work. Only the rear power windows would work not the front ones. It appears there is next to no current available from the electrical system to run these components. When I removed the cables after having been attached only a couple of minutes, and also when I had the battery attached to the vehicle and had the battery charger on it, I noticed that the alternator became VERY hot to the touch. This was not when the vehicle was running - only when it was charging from either the battery charger or from being jumpered on to another vehicle's battery. It appears nearly all of the current flowing into the electrical system is being lost to the form of heat at the point of the alternator, judging from how hot that alternator became. Could this indicate a bad alternator? Is there some component of an alternator such as a diode or something that could be causing a short within the system that is draining the battery and preventing it from starting the vehicle? Or is it possible that there is a short somewhere else? The fact that the alternator got so hot made me think that it could be at that point where the problem is, but I thought maybe it could be anywhere along the circuit and the whole thing may in fact heated up like that, but I thought a fuse would've blown somewhere or something. If I can save the expense of having it towed/hauled to a garage that would be great because I live in a rural area and a repair shop is quite a distance away from me. Thanks very much for any advice
  12. Hello fellow DJ owners. I have just completed the "big three" on my 2014 Journey. I did this in preparation for my aftermarket sound system i will be installing soon. I recommend that ANYBODY planning on adding an aftermarket amp or other high current devices to your DJ do the big three. The factory wiring under the hood in these vehicles is sub-par at best. The factory ground from the battery to chassis was maybe 8 gauge. Anybody adding anything electronic wise will benefit from this upgrade . The job was not terribly difficult to accomplish however gaining access to the battery terminals was a pit of a pain. It took a couple of hours but i was taking my time, everything worked out perfect, no problems. If you do a big three be sure to fuse the alternator to to battery positive. There is some debate whether this is necessary or not. You should always fuse within a foot of the battery. As for the sound system goes here it is: I am keeping the factory base 4.3 Uconnect, Relocating the rear door 6x9's to the far rear panels(there are "dummy" grills back there, for premium sound system maybe?) and keeping the dash 3.5's, and removing the stock front door 6x9's This is to maintain a load on the factory head unit so it will continue to send a signal to all four channels. (the 4.3 has six speakers but only four channels, the dash and front doors are wired in parallel) I will be tapping into those signals at the factory speakers using an AudioControl LC7i, then to my Polk 5 channel amp and out to my new Polk component speakers in the doors, and a Polk 8" sub woofer under the driver seat in a seald box build by myself(yes i got it to fit, barely). So i will end up with this: dash 3.5 and far rear 6x9's will receive stock head unit's 15 watts, and new components in the doors will get amplified 70 watts rms and 200 to the sub. So there it is in a nutshell. I will post an update once it is complete or if i have any problems with my plan i will let you know. I wanted to post and contribute something to these forums. I have been doing alot of reading on here and have gotten some good info.And now it is my time to give something back.
  13. I have a 2009 Journey R/T with 3.6L V6 AWD and for a while have been experiencing battery drain whenever the vehicle is left for more than a few hours. After several unsuccessful attempts at finding out the cause for this, I decided to temporarily install a 500A switch to isolate the battery from the rest of the vehicle's electrical system, to prevent having to jumpstart the vehicle every morning. This has been effective in this regard for a while now, however, the other day while travelling on the highway the vehicle started experiencing a loss of power for a second or so, then power would be restored, and this would randomly repeat for the remainder of my trip. Then, upon my arrival at my destination city, when coming up to a stop sign and the engine idled down, the power loss occurred again only this time the engine died. When I attempted to start it immediately after this, I found there was no charge left in the battery whatsoever - no dash lights,no sound....couldn't even shift from park without using the manual release button. I then used a charged battery to boost the vehicle, and it fired up, but after continuing to drive a short distance, the same thing happened again, I then noticed the battery symbol for the charging system had appeared. Then the vehicle could only been driven with limited power and only without using any headlights for a short time (constantly requiring me to press the accelerator to prevent idling too low) before it would die again with the battery drained. I have checked all the connections, all the cables, swapped the battery for a different one, removed the battery and jumpered it directly to another running vehicle, all with the same result. It will fire up, and run for a short time, then the charging system symbol will light up, and the engine will die shortly thereafter. It will run for a while jumpered to another vehicle, but even during this time the warning light will still come on. I removed the alternator and had it tested - it passed all tests and I was told it was good. I should also mention that this alternator was purchased and installed just 8 or 9 months ago, and the battery was only purchased a month or two ago. The belts appears to be working properly and with the correct amount of tension, and as far as I can see all of the conncections are solid and free of corrosion, etc. I'm uncertain as to where I should go from here, and after being left stranded several hours from home for a few days now (everywhere being closed for Christmas) and the expense of hotel rooms, I don't wish to throw a bunch more money away for the dealership to try all the things I've already tried, with no guarantee of results. I am planning to run a diagnostic tomorrow to see if this yields any additional information as to the possible cause of the problem, but am hoping maybe another forum member could provide some insight if they have encountered a similar issue in the past. Thanks in advance for your assistance.
  14. Ok, Ive had my 2012 Dodge Journey since May of 2012, bought it brand new. I have had issues with it since 2013, taken it to the dealership while it was under warranty- they kept it overnight and found nothing wrong with it. I am still having issues and going out of my mind!!! I suspect it's an electrical issue...here's a list of what has been going on: *I am now on my 3rd Battery, has had to be replaced about once a year after car just stops starting. Most recently I replaced the battery and 1 week later the Journey is back to not starting on it's own, it requires a jump every morning now. *ABS and Traction Control lights are both lit up on my dash, which in turn has disabled my cruise control. *USB Error, will detect my iPod and display the songs, but will not play. (Has worked before, just goes through phases where it stops functioning) *Bluetooth phone connection not working properly. I can call out and it recognizes my phone and loads the phone book, but no one can hear me when I talk. (I can hear the person on the other line, it has functioned in the past.) *Does not shift properly, RPMs run high and comes close to redlining at 60 MPH (This has only happened once, i pulled over and turned the car off and turned it back on and it stopped) Of course it is no longer under warranty, which is frustrating because I brought it in while it was under warranty and they treated me like I was crazy and said they couldn't find anything wrong with it. Any thoughts or insight before I take it back to Belle Tire, where I just had the newest battery put in??!!??
  15. I have a 2009 Dodge Journey SXT. New radio installed and recently the battery has enough juice to turn on the interior lights; but, it won't turn over. There are no error codes to report to mechanics. They had it after the first instance and couldn't rplixate the problem. Two days later, it needed another jump still no error codes. 6 days ago I had 2 engine lights: ESP Bas and an icon that looks like a car and tire tracks. Yesterday, the truck wouldn't turn over and pop-a-lock double jumped it to get it running: cables on the connectors via their box and cables on the battery from his battery and it worked! Just dropped off vehicle to mechanic to hopefully recreate the problem. If they hadnt told me to drop it off with a free loaner, I would have paid for a full engine diagnostic tomorrow. Any ideas on what wrong? It only has 68k miles, I bought it a month ago and so I'm a little concerned on how to handle
  16. Factory Battery

    Does anyone know the factory life of the 2014 Dodge Journey battery? Is it 3 years, 5 years 7 years? I bought this car used and didn't realize the battery is hidden. I'm now starting to read about battery issues. I'm hoping this purchase wont turn into a big mistake. The battery is on the drivers side behind the front wheel well. the book says one hour to replace. You can not see the battery at all. Usually the battery states...24 month, 36 month.....60 month...72 month life. And the owners manual does not show it in the specification area. When should I start worrying.
×