Jump to content

DizzyR/T

Journey Member
  • Content count

    23
  • Joined

  • Last visited

About DizzyR/T

  • Rank
    New Member

Profile Information

  • Region
    U.S. Northeast
  • Journey's Year
    None
  1. Looking for a new journey. (Possibly)

    I'm in pain but I did walk away no airbag deploy in a way I'm happy it didn't deploy and sock me right in the nose. But the car took a lot of damage for a rear ending it now has a broken windshield but I can safe I am alive at the speed I was hit the journey should have been a lot more worst looking but it did its job sucks it had to take that hit. I have the 2016 rt love that car had a few issues that I got over but overall I stand by this car looks and all. Now I'm trying to find a dj red with sunroof and gps and back up cam. I don't think they make a rt with a sunroof haven't found one.
  2. So the other day unfortunately I was in a accident my journey was rear ended pretty bad might just be Total loss I'm looking for a journey rt or gt with sunroof and everything else (back up cam, gps, roof rack) seems like they do no exsist. Has anyone have this paclage. Am I unaware of something. I want me another dj I had some lil issues but I loved my dj sad to see her all banged up. Also is there a suspension difference between the crossroad and the r/t gt?
  3. Oil leak can't locate source

    Haven't been able to figure out what the big Chung of rubber is from. However I found that the oil filter is leaking from around the gasket. Now I am not using a Mopar filter, I'm using the mobile 1 annual filter( which I change every oil change) I've went hand tight with a quarter turn with a wrench to half turn to 3/4 and still a slight leak. Can it just be the gasket. I'm just like how can oil keep getting past the gasket I'm not trying to go he man strength on the filter and break the housing because I've seen the amount of labor tht hoes into replacing those things. Has anyone had this issue with the oil filter its just like a very slow flow of oil.
  4. Oil leak can't locate source

    I'm just wondering if that random piece of rubber goes to the motor mounts or strut tower and it just has oil on it from where ever it maybe coming from. It a big piece of rubber I'd probably would have no oil if that piece went to something holding oil in. Again thanks in advance for you your guys in put truly helpful community.
  5. Oil leak can't locate source

    2016 Dodge journey rt 3.6L fwd. I'll have less than a quart between oil changes. But as of lately I'll notice oil drips not a whole lot but enough for me to raise concern(any bit of oil for that matter make me worry) I've added oil when I have noticed I was still in the safe zone on the dip stick but at the bottom put enough to bring it past the half way mark on the dipstick. The hose was taken off so I can get better pictures of the spots where oil is at. Another weird piece of info. I have a scanner my mil light came on for evap purge. But light went off on it's own. I scan it and it shows up as historical fault. Tried clearing it to see what hapoens, you know maybe it will repeat itself and it will not clear off. No mil light just shows when scanner is on.
  6. Oil leak can't locate source

    I do not see any leak or moisture around the valve covers at all. Now I am using the mobile one annual filter but I swap it out during regular oil changes I can't seem to figure it out. Now I found that rubber piece just hanging out on top of the box where my finger is pointed. Sorry for not knowing all the part names bare with me.
  7. Ok so this is my problem who ever designed this is not the smartest person. This box is mounted right under the seat and the yellow foam is the only protection they provided. You can see the board is burnt from the metal touching it. Funny part is this was one of my issues months back when I got the car. Wires are too short to relocate the box, the box always fell out. Design flaw. I think so.
  8. So I had it pulled out the car metal was touching the mother board inside. Reshaped it but it might be done. Couldn't tell if anything was shorted out. Found out it's not for the towing chasis control unit. Apparently I shouldnt have any parts from ram in the journey. Now to figure out if I order 1 when I got time and money to spare cuz summer here I don't need it. But I'm trying to fix it as soon as I can. I looked up the part and keep seeing the freemount (Fiat version) of this part.
  9. Ok I thought that was the issue since it was slightly dented. Been driving most ofthe day. Also the box of hot to the touch uncomfortably hot thought I hit jackpot on my problem. I'm going to see if I locate the module for the heated seat pull it out and bring it to my buddy see if it's damaged.
  10. What is this box under driver seat this box kept falling and now it's a lil dented wonder if this is my problem anyone know what this is?
  11. I've got told 2 things by friends. The switch and body module might need to be programmed. Just another issue for me to reconsider ever buying another dodge. I'll go Honda or Mitsubishi on my next purchase owned both brands in the past and never a issue stick to what you know right. Hopefully this junk gets recalled. I've seen many post about uconnect releasing this with known issues. Best part I was told being I'm the 2nd owner (used car) warranty doesn't transfer to next owner. I'ma just wait summer is here hopefully someone ends up finding a fix for the issue. Thanks for all the reply.
  12. Sucks I got this issue upon others ucconect is no help and that fix only fixes my heated seat not steering wheel. Sucks dodge didn't add a physical button. Called uconnect they were even stumped and even if it's defective they will do nothing about it. They got their money they don't give a crap.
  13. No warranty. But I'm dieing to see if someone else has had this problem. Seems like I'm the first 1 can't find this issue with any1 else. I've seen the issue where people's heated seats turn off intermediately but mine won turn off on driver side and passenger doesn't turn on and steering wheel. The blonde screen buttons don't work. @larryl
  14. I pulled the fuse out but it seems that I'm the only person with this problem and vehicle is 54k in and uconnect offers no damn help with their junk. Not my first issue, experienced Bluetooth issues n had to reset it, seems uconnect doesn't want to accept the fact their units are defective. Wish it would have had physical buttons to cancel out what could be the issue.
×