Jump to content

All Activity

This stream auto-updates     

  1. Today
  2. Yesterday
  3. 2017? Is it still under warranty? It would seem that if no warranty, you have found the place to start in the other thread that you posted this problem too. I would be inclined to start with what has worked for others as posted in that thread.
  4. as it happens that a lot of times simple things can be missed and expensive parts end up getting replaced before they find the real problem.glad you responded and gave your fix
  5. We just experienced the same issues as previously mentioned. 3 days after replacing the altenator the battery light came on and the radio powered off speedometer quit working ac powered on and off and several dash lights came on traction control, brake, abs battery ect.. the battery tested good three times and bad once . Alternator read good . After checking all the connections we found the power supply plug /end to the alternator was not plugged in correctly. A small clip inside the plug was broken and would not allow it to click in place. After replacing the plug the problems seem to be solved .
  6. Just joined this forum and I was looking over the posts from years past. I have a 2017 Crossroad Edition and I have pretty much the same issue: driver's side panel will not operate any of the windows, both the rear window/panels will not function, only the passenger panel/window works, it's also the only panel that's lit. Power locks and power mirrors are NOT affected, both work. I tried the battery disconnection trick but that didn't work. I pulled the power window fuse and replaced it but still nothing. My only guess would be checking/replacing the window control module behind the driver door panel, but I'm not mechanic so I would appreciate any help given.
  7. Rough engine start for 20 seconds only

    Is P301 the only code you are getting? A short term rough idle at start up may be the result of the throttle not working correctly while cold. It is common for a sensor to fail, something that controls cold idle like a MAS or MAP sensor. During the summer months, cold idle will only last a very brief time before the RPM's drop to idle and the engine smooth's out. If one of the sensors are bad, the cold idle would be rough. In cold weather, this condition may last a couple of minutes.
  8. Last week
  9. Just joined this forum and I was looking over the posts from years past. I have a 2017 Crossroad Edition and I have pretty much the same issue: driver's side panel will not operate any of the windows, both the rear window/panels will not function, only the passenger panel/window works, it's also the only panel that's lit. Power locks and power mirrors are NOT affected, both work. I tried the battery disconnection trick but that didn't work. I pulled the power window fuse and replaced it but still nothing. My only guess would be checking/replacing the window control module behind the driver door panel, but I'm not mechanic so I would appreciate any help given.
  10. Hey guys, I have a 2014 Dodge Journey. When I first start up this beast (I have nothing on at the start) I have a rough start (SUV shakes, engine sounds rough) this only lasts for about 20 seconds. Then the shaking stops, and everything runs very smoothly. That point I turn on a/c or heater. I have changed the plugs about 3 weeks ago, I also get that P301 code so I changed the coil in #1. Even tried swapping the new coil in a different spot. Nothing seems to make a difference. Anyone with any tips ? Thanks
  11. Heater hose failure

    Thanks for all the help! The journey is up and running better than ever! Thanks again!
  12. Heater hose failure

    Hopefully your Journey is on the road to recovery.
  13. Heater hose failure

    Update 2- went this morning to do the heater core flush, popped hood and coolant reservoir was empty, popped open radiator cap and no visible coolant. No signs of coolant leaks anywhere in vehicle or under vehicle. I added approx 3/4 gallon of coolant and I now have heat in passenger compartment, still have check engine light for the coolant temperature sensor, but so far all fluid temps seem to be normal. Hope that might be the fix.
  14. Where do you live?

    Go here to introduce yourself. https://www.dodgejourneyforum.com/forum/2-welcome/ To post a topic or question, go to the appropriate section of the forum. i.e. enging, wheels, tires, climate control, etc.
  15. purchased a 2016 dodge journey with the 2.4L. Started off getting hot (230_250) range. Aleays shut off before any higher. Was always a low radiator. Replaced thermostat upper radiator hose thermostat housing. Performed a pressure check with no drops in preasure after 15 or 20 minutes. After replacing all parts. Water temps never get above 200. But notice that there are bubble going to over flow resivoir after engine is shut down. Performed a compression check and all cylinders are above 150. 165-185. The main question is is why am i getting bubbles in the resivoir after shutting it off and sometimes the coolant doesnt always return from the overflow tank? Coolant is not boiling.
  16. Dodge journey coolant issues

    This section is reserved for Q & A on how to use this forum. For information pertaining to the Dodge Journey, please post in the appropriate section.
  17. New Journey in NOVA

    Cool. I lived in Centreville, Falls Church, Arlington and Sterling back in the days before I got married (and moved around a lot, lol)
  18. Heater hose failure

    Update- I tried to check and see if it is air in the line, found that it bubbles a bit and lost a little bit of volume. I did that till there were no more bubbles. Still no heat in the passenger compartment. Both lines were warm but not so hot I couldn’t touch it. I did a very quick test drive since temps were normal. Coolant temp went to “overheating” around 280; stayed there for about 15-20 seconds then immediately dropped down to >100 and the lighting bolt dash board light and a check engine light. Got it home and it popped up the OBD code P0117. I was able to touch the beauty cover with my hand and I was able to keep my hand there with no problem. Could the wiring harness be shorted for this sensor and would this cause the lack of heat in the cab? The heat worked on the morning when the heater hose blew. i will try the heater core flush tomorrow and see if anything there is off.
  19. New Journey in NOVA

    I live in Manassas.
  20. Heater hose failure

    I will definitely try that when it cools down, both lines are hot but not so hot that I can’t touch it
  21. Heater hose failure

    If you had heat before the leak but not now it is hoped it is just an air bubble. It is a common problem on any car. You need to note if both heater lines are hot to know if you have flow. Then we can try to determine if it is air or something more serious. If it is air, you may be able to force it out by squeezing the inlet line and pushing the bubble thru. Remove the radiator cap and watch for bubbles and a declining level.
  22. Heater hose failure

    as the above post ,were both heater hose hot after running the heater that long if only one was hot id say you have a blocked heater core as it isnt letting the hot water to pas thur the heater core,you might want to do a reverse heater core flush since your journey is a 2013
  23. I purchased a 2016 dodge journey with the 2.4L. Started off getting hot (230_250) range. Aleays shut off before any higher. Was always a low radiator. Replaced thermostat upper radiator hose thermostat housing. Performed a pressure check with no drops in preasure after 15 or 20 minutes. After replacing all parts. Water temps never get above 200. But notice that there are bubble going to over flow resivoir after engine is shut down. Performed a compression check and all cylinders are above 150. 165-185. The main question is is why am i getting bubbles in the resivoir after shutting it off and sometimes the coolant doesnt always return from the overflow tank? Coolant is not boiling.
  24. New Journey in NOVA

    Welcome! What part of NOVA?
  25. Heater hose failure

    So I have run heat full blast for about 30 minutes with no heat in the passenger compartment, any other ideas?
  26. New Journey in NOVA

    welcome to the group, mine is silver as well
  27. Heater hose failure

    did you try what he suggested?if you have trapped air in the system you will have problems
  1. Load more activity
×