Jump to content





journeyfamily

no heat coming from roof vents in 2nd and 3rd row

Recommended Posts

hi all

my daughter has been complaining that there is cold air coming out of the roof vents, i kept telling her not to be silly, as the heat is on, but i was wrong :shrug: , can anyone tell me why with the heat on, im blowing cold air out of these roof vents.

thanks again

Paul

Share this post


Link to post
Share on other sites

Is the rear heat adjusted in the 8.4 uconnect? Just a thought. I shut my rear off, as there is hardly ever anyone in he back seats of our journey.

Share this post


Link to post
Share on other sites

I keep my rear heat on all the time to evenly heat the whole car. I was in your same situation, until I read the manual (when all else fails!) and found the controls for the for the rear heat. Driver's side is set to 73, back set to 74, and passenger side set to 75. It takes very little time to warm up, in these frigid temps. Although I do not use the third row very often, having the rear heat is nice. And you can lock the rear heat on the screen controls.

Share this post


Link to post
Share on other sites

yes i have been through the screen and i cant see anything, the rear heat is set to heat and is on, but cold air is coming out of the vents

Share this post


Link to post
Share on other sites

yes i have been through the screen and i cant see anything, the rear heat is set to heat and is on, but cold air is coming out of the vents

You say the heat is on, but what is the temperature set to?

Share this post


Link to post
Share on other sites

yes i have been through the screen and i cant see anything, the rear heat is set to heat and is on, but cold air is coming out of the vents

journeyfamily,

If you've gone through all the HVAC settings and are confident that it's not an adjustment issue, get this to the attention of your dealer for further handling.

Share this post


Link to post
Share on other sites

Does anyone know if the rear heater has its' own heater core? I traced the heater core pipes for as far as I can see with the cover on. It comes out on the front side of the engine (V6), down by the dip stick and then splits; one going left, one going right. Then, the right one spits again into 2 pipes!

Share this post


Link to post
Share on other sites

On my 7 seater I have additional control panel

on the roof in 2nd row and have them set as well.

Edited by bigtsr

Share this post


Link to post
Share on other sites

I have no idea what the roof mounted controls are set to. It really doesn't matter because I have the rear seat AC/Heat Locked on the screen controls.

Share this post


Link to post
Share on other sites

Everyone with their fancy rear heaters and what-not.

I have only a front unit. It really doesn't take long to heat/cool the whole car.

What's next! Power windows and door locks? Power heated seats? The insanity of it all! LoL.!

Share this post


Link to post
Share on other sites

My 09 also blows cooler air at the top, warmer air at the feet. Always has, car warms up really fast. I just assumed that's the way the automatic 3 zone heat works. If I keep it on manual and blow at the feet, it blows hot. I have mine on auto 98% of the time, just change the temp. I usually have my temp synced at first, then adjust as it warms up.

Another thing, you have to be moving a bit before the heat really shows up in the rear overheads. Starting the car and letting it idle won't cut it. On really cold days it sometimes takes 15 mins for really hot air.

Hope this helps ya!

Share this post


Link to post
Share on other sites

Everyone with their fancy rear heaters and what-not.

I have only a front unit. It really doesn't take long to heat/cool the whole car.

Ha! It's nice to be able to to set the 3 zones differently to accommodate the whiners (i.e. wife and kids). I like it a bit chilly, but the wife is ALWAYS cold. The kids can adjust their own. I like it this way as I get what I want instead of what they want.

Share this post


Link to post
Share on other sites

@journeyfamily  @Everybody Just wondering if you ever find out what caused it? Im having a bit similar problem, mine blows hot and cold on 3rd row floor vent! absolutely no air on 2nd and 3rd roof vents. Im thinking its a fuse or lose connection somewhere which I dont know. Definitely the rear AC is working just not the control to flow air to the roof vent. Thanks 

Share this post


Link to post
Share on other sites

Oh my goodness! I found on another thread it was the Cabin airfilter! I just replaced mine and 2nd and 3rd row roof vents stopped working! I guess it was not direct fit?! Picked up the old one in the garbage can and voila AC came back on 2nd and 3rd row! So guys make sure to buy exact fit cabin air filter next time. Good night!

Share this post


Link to post
Share on other sites

i bought a k/n cabin air filter for my 14 crossroad, remove filter quick wash and rinse shake out the water and let it dry a little and then spray with a little freshener and put it back in no problems with mine. i can not believe just replacing your filter would stop your roof vents from working maybe you didnt take the plastic off the filter is all i can figure....( sorry the devil made me type that) but seriously something else has to have been the cause... 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×