Jump to content





12JourneyOnr

underhood fuse box issue

Recommended Posts

1]With the lid off, I noticed a disconnected wire clip entering through a slit in the lid into the box.  Where should it be connected in the box?

2] could this have anything to my radio not working? [I have already tried to R&R the radio fuse in the interior fuse box [unsuccessfully].

Share this post


Link to post
Share on other sites

1 hour ago, 12JourneyOnr said:

Year=2012; bought new.

no pictures.

 

Cant really help with out a visual.

Share this post


Link to post
Share on other sites

Thats a new one ....take it back to where you bought it

Share this post


Link to post
Share on other sites

I doubt that  is factory.  Gotta be an aftermarket add on, maybe alarm, remote starter , something like that.  You can tell it has been pinched by the cover.  If it was factory it would come in a Wireloom.   -

Share this post


Link to post
Share on other sites

Thanks, gents.  Radio is NOT aftermarket.  Maybe It belongs to either to the remote door opener OR the heated seats, both 'aftermarket' items added at dealer expense during original purchase.  I'll check it out.

Share this post


Link to post
Share on other sites

Don't think the dealer would have done a hack job like that (at least I hope not). Dealer would have used OEM parts that didn't require running a wire into the fuse box so the lid pinches it.....

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×